Bug report #14419

Categorised styling on SQL Server view

Added by David Morgan about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/MSSQL
Affected QGIS version:2.14.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22400

Description

When I apply a categorised style to a SQL server view that uses 'ROW_NUMBER() OVER (ORDER BY Waste.tblCollectionPoint.UPRN) AS UID' to create a unique numeric ID all features are displayed according to the 'Else' style, even though all categories are shown in the styling dialog and the Layers Panel. When using a unique numeric id directly from one of the source tables styling seems to work OK. This only affects 2.14.0, styling works as expected in 2.12.3 and 2.13 code revision ae52aab and earlier versions. Graduated styles appear to be OK. SQL server version is 2008 R2.

History

#1 Updated by Nyall Dawson about 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #14402

Also available in: Atom PDF