Bug report #14402

Labels and MSSQL layers

Added by Andre Jesus about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Labelling
Affected QGIS version:2.14.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22383

Description

I'm getting random results when I try to use labels with MSSQL layers. Sometimes It appears, sometimes It doesn't.

It works fine with number fields (int, real, float, seq), but with strings (varchar, nvarchar) or dates (date, datetime) It is totally random when It will appears or not. I tried to pin It down what is causing this but I couldn't find the cause.

Using QGIS 2.14.0 on a Windows 7 64 bits. Database MS SQL Server 2008 R2.


Related issues

Duplicated by QGIS Application - Bug report #14465: Styling of Microsoft SQL data not working Closed 2016-03-12

Associated revisions

Revision 30449e57
Added by Nyall Dawson about 4 years ago

Fix fetching subset of attributes with mssql (fix #14402), add test

Revision 63d6f7b4
Added by Nyall Dawson about 4 years ago

Fix fetching subset of attributes with mssql (fix #14402), add test

(cherry-picked from 30449e577f0cd432bd8c60787743fba54c1e51b9)

History

#1 Updated by Andre Jesus about 4 years ago

If a export the layers to shapefile or sqlites, for exemple, It works fine. All labels are displayed.

#2 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF