Bug report #14397

QGIS 2.14 Layer Rule based styling not being applied to layers

Added by Brian London over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:2.14.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22378

Description

Since installing 2.14 our projects no longer render Rule-based labelling, even though it shows a count against each rule (this is a polygon layer with a GEOMETRY column of type POLYGON). Also our layers that have Categorized symbols no longer are displayed (this is a point layer with a GEOMETRY column of type GEOMETRY). This function was working at weekly release QGIS-OSGeo4W-2.13.0-4-Setup-x86_64.exe, but not working in QGIS-OSGeo4W-2.13.0-5-Setup-x86_64.exe when the new 2.5D style was added.

Both of these layers are being read from MS Sql Server 2012, although layers of Type Line with a GEOMETRY column of type GEOMETRY renders properly.

History

#1 Updated by Nyall Dawson over 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #14402

Also available in: Atom PDF