Bug report #14169

Crash when clicking "save as..." when the source file is CSV or SHP

Added by Shai Efrati almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.12.2 Regression?:No
Operating System:Arch Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:22171

Description

While trying to "save as..." a CSV or SHP file - QGIS crashes.
When running it through the terminal - i saw the following message:
[1] 8681 segmentation fault (core dumped) qgis

Might be related to #14123

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Category changed from Browser to Vectors
  • Status changed from Open to Feedback

Cannot replicate, please attach sample data.

#2 Updated by Gaelic Miko almost 5 years ago

Hi.

I am also using archlinux and have the same issue with the master from git (2.13) from today (and also last week) using the qgis-git package

So maybe there is some problem with qt / gdal / ...

Are there any suggestions how to debug that?

#3 Updated by Sandro Santilli almost 5 years ago

Some hints:
- Check with `ldd` that the same version of libraries are used by qgis and gdal (and there are no duplicates).
- Run qgis under valgrind and save the report somewhere (will be slooow, but usually helpfu)

#4 Updated by Sandro Santilli almost 5 years ago

If you're also using sqlite 3.10 I think this could be marked as a duplicate of #14123

#5 Updated by Gaelic Miko almost 5 years ago

I can confirm that sqlite is the problem. I downgraded it an now I have no problems with 'save as'.

@Shai, can you confirm? I yes we can mark it as duplicate ...

#6 Updated by Gaelic Miko almost 5 years ago

https://aur.archlinux.org/packages/qgis/ the discussion here also suggest that the problem is solved by downgrading sqlite.

#7 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

duplicate of #14123

Also available in: Atom PDF