Bug report #14123

Crash when choosing "Save As" on a layer with sqlite 3.10

Added by Doug Newgard almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:Yes Copied to github as #:22125

Description

QGIS segfaults when choosing "Save As" from the right click menu of a layer when using sqlite 3.10.0+. Works fine with sqlite 3.9.2.

Not sure if this is a problem with sqlite, gdal (2.0.1), libspatialite (4.3.0a), qgis (2.12.3), or whatever, so I'm starting at the high point in the stack.

bt and bt full with debugging symbols attached. I don't have symbols for Qt included, but can get them if you need them.

qgis_bt.txt Magnifier (8.14 KB) Doug Newgard, 2016-01-17 09:49 AM

qgis_bt-full.txt Magnifier (39.2 KB) Doug Newgard, 2016-01-17 09:49 AM

History

#1 Updated by Doug Newgard almost 5 years ago

Files didn't attach the first time.

#2 Updated by Sandro Santilli almost 5 years ago

I cannot reproduce with current qgis master (69cb0c4ed3174946c82e32dad4af5a12275079fc) built and running against SpatiaLite Version 4.4.0-topo-1 (as reported by Help->About)

#3 Updated by Sandro Santilli almost 5 years ago

  • Status changed from Open to Feedback

Oh, and I'm usign GDAL 1.11.1 (built and run against)

#4 Updated by Victor Ducrot almost 5 years ago

I experience the exact same issue on ManjaroLinux 15.12:
qgis 2.12.3-1
libspatialite 4.3.0.a-1
gdal-filegdb 2.0.r32195-1

Qgis crashes when trying "save as" (layer) with sqlite 3.10.1-1. Works fine with sqlite 3.9.2-1

#5 Updated by Donovan Cameron almost 5 years ago

I'd like to test on Master, but can't because it won't compile on Arch Linux as result of this #13686

I'm running Arch Linux like the OP:
QGIS 2.12.3 (99ac688)
GDAL/OGR 2.0.1 (r33037)
Spatialite 4.4.0-RC0 (from fossil)
SQLite 3.10.1

@Sandro What version of sqlite are you running for the qgis master build?

#6 Updated by Doug Newgard almost 5 years ago

Just tested with current QGIS Master and sqlite 3.10.2, same result.

#7 Updated by Antal Kosza almost 5 years ago

Same crash and debuginfo here (debian sid, gdal 1.11.3 and sqlite 3.10.2, qgis master and 2.8.4).

#8 Updated by Sandro Santilli almost 5 years ago

My version of sqlite is 3.8.2 -- Just tested again with qgis master (964ae1f) and I can open a layer from a spatialite file and right-click-save-as another spatialite file. No crash. Do you have a way to test with sqlite 3.8 ?

#9 Updated by Doug Newgard almost 5 years ago

As it seems to have shown up with 3.10, I wouldn't exepct 3.8 to have any problems

#10 Updated by Paolo Cavallini almost 5 years ago

See also #14253

#11 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Feedback to Open
  • Affected QGIS version changed from 2.12.2 to master
  • OS version deleted (4.3.3)
  • Operating System deleted (Linux (Arch))
  • Target version set to Future Release - High Priority
  • Priority changed from Normal to High
  • Category set to Vectors

#12 Updated by Paolo Cavallini almost 5 years ago

  • Priority changed from High to Severe/Regression
  • Target version changed from Future Release - High Priority to Version 2.14

#13 Updated by Even Rouault almost 5 years ago

  • Target version deleted (Version 2.14)

This is a Unix specific issue since SQLite 3.10.0 (where the unixCurrentTime implementation of the xCurrentTime SQLite VFS function has been aliased to NULL). See https://trac.osgeo.org/gdal/ticket/6360 for a GDAL fix

#14 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Feedback

rouault - wrote:

This is a Unix specific issue since SQLite 3.10.0 (where the unixCurrentTime implementation of the xCurrentTime SQLite VFS function has been aliased to NULL). See https://trac.osgeo.org/gdal/ticket/6360 for a GDAL fix

so we should close this as "upstream", right?

#15 Updated by Even Rouault almost 5 years ago

Note from Sebastiaan Couwenberg :

"""
gdal (1.11.3+dfsg-3) is now available in unstable and gdal (1.11.4+dfsg-1~exp2) in experimental with the fix for this issue.

Ubuntu has gdal (1.11.3+dfsg-3) in proposed for xenial, hopefully they won't stall moving it to release like grass (7.0.3-1) & netcdf (1:4.4.0-1) and their related packages.
"""

#16 Updated by Paolo Cavallini almost 5 years ago

I confirm, fixed in current Sid. Thanks Even and Bas.

#17 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to up/downstream

Also available in: Atom PDF