Bug report #14037

frequent crash when editing data in relation forms (standard relation form-widget, generated by qgis)

Added by Gerhard Spieles over 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Relations
Affected QGIS version:master Regression?:No
Operating System:win Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:22050

Description

When I edit data in in the subform of the standard generated form, qgis often crashes.
A jpg that shows a form in edit mode with generated crash and the layer properties of the layer are attached.

relationwidget-crash-qgis.jpg (204 KB) Gerhard Spieles, 2015-12-25 10:42 AM

layerproperities_relations.jpg (148 KB) Gerhard Spieles, 2015-12-25 10:42 AM

relation_and_emdeded_form_212_crashqgis.jpg (189 KB) Gerhard Spieles, 2015-12-26 07:19 AM

projectproerities_relations.jpg (92.5 KB) Gerhard Spieles, 2015-12-26 07:19 AM

emeded_form_relationreferenz.jpg (287 KB) Gerhard Spieles, 2015-12-26 07:19 AM

vg_flaechenmanagement.zip (475 KB) Gerhard Spieles, 2016-01-24 05:44 AM

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Feedback

Hi, why blocker? it works fine in official qgis releases?

#2 Updated by Regis Haubourg over 4 years ago

I would let it as blocker, we encounter such crashes, but they are very difficult to catch and reproduce. We also have some with custom UI forms.

#3 Updated by Gerhard Spieles over 4 years ago

In QGIS 2.12.2, crash occurs also (see attached jpg). In 2.12.2 the data in embeded forms are not schown and when you only activate the edit mode in subform, without taking any changes, QGIS ask to save and write a NULL Value in the relation field.

I have tested this behaviour and it seems, that crash and QGIS-asking to save for not taken changes only occurs, when relationreferences with embeded forms are activated. Screenshots of the embeded forms properities and relationdefinitions are attached.

For normal forms with realtion and no emeded forms in subform via relationreference, QGIS works fine.

#4 Updated by Gerhard Spieles over 4 years ago

In QGIS 2.10, all worked fine without problems.

#5 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Open

#6 Updated by Tudor Bărăscu over 4 years ago

Hi Gerhard,
It would be really nice if you'd attach a project with data so that the issue is easily reproducible.
All the best

#7 Updated by Gerhard Spieles over 4 years ago

Hi Tudor,

testproject attached.

I have tested with lates master. The crash occurs, when in layer "pflegemassnahmen", properities, fields, in field2 in the relation reference widget is buit with an expression (in my case : nr || ', Adat: ' || "auftr_dat" || ', Fa: ' || "firma"). If there ist only the field 'nr' choosen, then it seems to work without crash.

Another strange behaviour since 2.12: when you only activate the edit mode in subform, without taking any changes, QGIS ask for saving changes, when you press edit button again.

#8 Updated by Jürgen Fischer almost 4 years ago

  • Subject changed from qgis crash often editing data in relation forms (standard relation form-widget, generated by qgis) to frequent crash when editing data in relation forms (standard relation form-widget, generated by qgis)

#9 Updated by Jürgen Fischer almost 4 years ago

  • Assignee deleted (Matthias Kuhn)

#10 Updated by Matthias Kuhn almost 4 years ago

  • Status changed from Open to Feedback

I just tried hard to reproduce the crash with the attached project but I did not succeed.

Is this still an issue?

If yes, can you provide more detailed steps to reproduce (which fields to edit, when to save what...).

#11 Updated by Gerhard Spieles almost 4 years ago

Hi Matthias,

it seems, that this is still no problem.

Thank you for for the work and excuse, that i haven`t tested it earlier.

Gerhard

#12 Updated by Andreas Neumann almost 4 years ago

hm - what means "this is still no problem"?

Do you mean the issue is gone and we can close the issue or are you still experiencing the issues with the current master version?

#13 Updated by Gerhard Spieles almost 4 years ago

The issue can be closed.

#14 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Also available in: Atom PDF