Bug report #1393

Crash when using point vector layer with symbology "continuous colours"

Added by bishopbr - over 11 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:11453

Description

Qgis 1.0.0 Kore preview 2 crashes consistently on Ubuntu 8.10. after installing update from the ppa.launchpad.net/jef-norbit/ubuntu/ repository, can reproduce crash when using continuous colour symbology.
Qgis crashes after I have chosen Min and Max colours then pressed ok. Using "continuous colours" on a "elevation" attribute, with all negative values.

Attached shp file for testing,

test_shp.tar.gz - test shp file. Use the elevation attribute to replicate symptoms. (164 KB) bishopbr -, 2008-11-11 02:59 PM

qgis_crash_trace.txt Magnifier - Copy of terminal output when Qgis started from there. (5.96 KB) bishopbr -, 2008-11-11 03:09 PM

History

#1 Updated by Marco Hugentobler over 11 years ago

I also observed this problem with different shape files. I think it has to do with the GDAL/OGR version that comes with ubuntu8.10. When I tried with a self-compiled GDAL 1.6, the problem was gone.

Marco

#2 Updated by Maciej Sieczka - over 11 years ago

I can't reproduce the crash either. Tried different min/max colors and classification fields.

QGIS trunk SVN . GDAL 1.6 SVN trunk (today's). QT 4.4.3. Debian testing amd64.

#3 Updated by bishopbr - over 11 years ago

Confirmed that fault goes away when using gdal 1.6.0 svn trunk and qgis unstable compiled on Ubuntu 8.10.

GDAL 1.6.0 has not been released yet, therefore can we get this version into Ubuntu 8.10 with the next preview release of Qgis?

Brian

#4 Updated by Paolo Cavallini over 11 years ago

See also #1575

#5 Updated by Marco Hugentobler over 11 years ago

  • Status changed from Open to Closed
  • Resolution set to wontfix

I'm closing this bug as it seems to be a problem of the ubuntu gdal package. Don't get me wrong, this does not mean it is not a problem. It's just that qgis bugtracker is about bugs that can be fixed within the qgis codebase.

#6 Updated by Anonymous almost 11 years ago

Milestone Version 1.0.2 deleted

Also available in: Atom PDF