Bug report #13794

Memory behaving strangely

Added by Rhenriques Henriques about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.12.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21820

Description

Hi

First let me say that QGIS 2.12 is probably the most stable QGIS version ever under MacOSX. I'm using it in the latest update of El Capitan and it's very stable. The only thing that worries me a bit is that, after some work done, if we edit a shapefile layer (attributes or geometry), QGIS will take a long time to save. This will happen even with very simple layers. There's possible something to be done here related with memory management. A restart in QGIS solve things but it would be better to avoid this. Despite this behavior, everything is working great.
Cheers

R. Henriques

History

#1 Updated by Nathan Woodrow about 5 years ago

Do you have any plugins enabled?

#2 Updated by Rhenriques Henriques about 5 years ago

Yes Nathan, a lot of them. I need most of them all :-)
It can be a plugin that is causing this issue, yes. The problem is that it takes some dozen of minutes of work to notice any slowdown. So it will be difficult to trace back the culprit by activate and deactivate sets of plug-ins. Do you have a possible suspect?
Cheers

R. Henriques

#3 Updated by Nyall Dawson about 5 years ago

The "rectangles, ovals,..." plugin is one culprit I'm aware of

#4 Updated by Rhenriques Henriques about 5 years ago

Hi Nyall

I've been working today without "rectangles, ovals..." installed. Did not work for too long but the problem did not show up again. In the next few days I'll be working harder with QGIS and I'll have a chance to test if this was the cause.
Cheers

R. Henriques

#5 Updated by Giovanni Manghi about 5 years ago

  • Category set to Vectors
  • Status changed from Open to Feedback

#6 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

closing for lack of feedback.

Also available in: Atom PDF