Bug report #13754

Selected Multipolygon by Rectangle / "on the fly" reprojection = Only few entities are selected

Added by Julien Ancelin about 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21781

Description

Hi,

The graphical selection on multipolygons, does not recover all entities when using reprojection "on the fly".
example:

multipolygon CRS 3857 + qgis project CRS 3857 + selection of all entities: works well

multipolygon CRS 3857 + qgis project CRS 2154 ("on the fly" reprojection) + selection of all entities: Only few entities are selected

test_bug_select.sqlite (126 KB) Julien Ancelin, 2015-11-09 12:17 AM

wb1.dbf.zip (24.2 KB) Giovanni Manghi, 2015-11-10 01:15 AM

Associated revisions

Revision 0a83f182
Added by Jürgen Fischer over 3 years ago

selection by polygon: use 40 instead of 4 points for selection rectangle for more accurate transformation (fixes #13754)

Revision a7dcaad8
Added by Jürgen Fischer over 3 years ago

selection by polygon: use 40 instead of 4 points for selection rectangle for more accurate transformation (fixes #13754)

(cherry picked from commit 0a83f182f3e8aea684163096f70efc9f38399ad2)

History

#1 Updated by Giovanni Manghi about 4 years ago

  • Category changed from Map Tools to Map Canvas
  • Priority changed from Normal to Severe/Regression
  • Target version set to Future Release - High Priority
  • Affected QGIS version changed from 2.12.0 to master

This worked as expected until 2.8.3

Actually in 2.8.3 if selecting outside the boundaries of a certain layer CRS QGIS shown this message

CRS Exception: Selection extends beyond layer's coordinate system

that is not anymore the case in qgis > 2.8.3

#2 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Feedback

Can you give some more detail? I tried with a few multipolygon layers and couldn't reproduce

#3 Updated by Julien Ancelin about 4 years ago

Here is a multipolygon layer with a "3943 crs".

if the qgis project is in crs 3943, no selection problem.
If I reprojects on the fly with "crs 3857" and I'm trying to select all: some multipolygones are not selected

#4 Updated by Giovanni Manghi about 4 years ago

  • File wb1.dbf.zip added
  • Status changed from Feedback to Open

attached another small dataset.

#5 Updated by Nyall Dawson almost 4 years ago

  • Status changed from Open to Feedback

Julien - I get an error opening that dataset

Giovanni - I can't reproduce using your dataset.

#6 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Feedback to Open

Giovanni - I can't reproduce using your dataset.

open the dataset I attached, enable otf to 2154, try do a selection. Cheers!

#7 Updated by Saber Razmjooei over 3 years ago

  • Status changed from Open to Feedback

I can't reproduce with the latest master.

#8 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Open

zoom out to ~300.000.000 and try select all features by click and drag.

If you zoom in enough selection seems to work, but not if you zoom out enough.

#9 Updated by Jürgen Fischer over 3 years ago

  • Status changed from Open to Closed

#10 Updated by Jürgen Fischer over 3 years ago

  • Resolution set to fixed/implemented

Giovanni Manghi wrote:

zoom out to ~300.000.000 and try select all features by click and drag.

If you zoom in enough selection seems to work, but not if you zoom out enough.

It only worked when the projections were somewhat alike. The four points of a rectangle around the extent of the layer in EPSG:2154 were transformed to a polygon in EPSG:3857 that excludes Arabia. 0a83f182 adds 9 points to each rectangle edge and improves it. Selection for more "stronger" projections might still "fail" and need more points (e.g. polar and non-polar).

Also available in: Atom PDF