Bug report #13543

Apply button doesn't work in Layer Labelling Settings dialogue

Added by Frank Sokolic about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21585

Description

Clicking the Apply button doesn't update the labels on the map when using the Layer Labelling Settings dialogue. However, when using the Labels tab in the Layer Properties the Apply button works.

Associated revisions

Revision d7094968
Added by Nyall Dawson about 4 years ago

Fix crash in label property dialog (refs #13543)

Revision f50e1a75
Added by Nyall Dawson about 4 years ago

Fix broken apply button in label config dialog (fix #13543)

History

#1 Updated by Regis Haubourg about 4 years ago

Confirmed here. Should be marked as blocker for 2.12, it's a regression, and a very usefull feature in every day's workflow since labeling is an iterative task.

#2 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Feedback

Likely fixed in d7094968a116448f3aed4d030c56a2297981e40c, can you confirm?

#3 Updated by Frank Sokolic about 4 years ago

Just updated Master and the problem still occurs.

#4 Updated by Nyall Dawson about 4 years ago

Can you post some steps to reproduce? I still can't trigger this issue

#5 Updated by Frank Sokolic about 4 years ago

  1. Make a layer active in the layers panel
  2. Click the Layer Labelling Options icon on the toolbar (or Layer > Labelling from the menu bar)
  3. Make changes to the label settings
  4. Click Apply, labels don't get updated on the map canvas
  5. Click OK, dialogue box closes and labels are updated

This is on Ubuntu 15.04 64 bit running QGIS master.

#6 Updated by Saber Razmjooei about 4 years ago

  • Status changed from Feedback to Open
  • Operating System deleted (Ubuntu)
  • OS version deleted (15.04 64 bit)

I can confirm in debian jessie and Windows. It is indeed a regression.

#7 Updated by Saber Razmjooei about 4 years ago

  • Priority changed from Normal to Severe/Regression

#8 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF