Bug report #13474

"Show plus sign" tick mark in Layer labeling setting not saved in project file

Added by magerlin - about 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:Sebastian Dietrich
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21521

Description

In "Layer labeling setting", "Formatting" it is possible to tick mark "Show plus sign".

It works as expected but is not saved in the .qgs project file. Next time you open the project, you will to manually tick it again.

It has been so during several of the latest versions.

Associated revisions

Revision df4c0c12
Added by Sebastian Dietrich almost 4 years ago

fix loading the labeling-setting to show a plus-sign next to numbers
(fixes #13474)

Revision 1dc8fc3c
Added by Jürgen Fischer almost 4 years ago

Merge pull request #2716 from SebDieBln/LoadShowPlusSign

[Bugfix] Correctly load the labeling-setting to show a plus-sign next to numbers (fixes #13474)

History

#1 Updated by Giovanni Manghi about 4 years ago

  • Target version deleted (Version 2.12)

#2 Updated by Sebastian Dietrich almost 4 years ago

  • OS version deleted (7)
  • Affected QGIS version changed from 2.10.0 to master
  • Operating System deleted (Win)
  • Assignee set to Sebastian Dietrich
  • Status changed from Open to In Progress

#3 Updated by Sebastian Dietrich almost 4 years ago

  • % Done changed from 0 to 100
  • Target version set to Version 2.14
  • Pull Request or Patch supplied changed from No to Yes

magerlin wrote:

is not saved in the .qgs project file

Actually it is saved in the project file, but it is not correctly read back from it.

See PR 2716 for a solution.

#4 Updated by Jürgen Fischer almost 4 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF