Bug report #13401

WFS Cache Features option does not work anymore

Added by zicke - over 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21452

Description

In older versions the "Cache Features" option could be used for downloading only the features of the current map extent. When zooming and/or panning the feature request was repeated. At the moment it only downloads the features intersection the current map extent once but does not refresh requests after zooming/panning.


Related issues

Related to QGIS Application - Bug report #13117: cached wfs not downloading new features while panning Closed 2015-07-15

History

#1 Updated by zicke - over 4 years ago

  • Priority changed from Normal to Severe/Regression

#2 Updated by Jukka Rahkonen over 4 years ago

If I have understood it right the meaning is that if "Cache Features" is checked then features are really cached as the name suggests and only one GetFeature with the BBOX of the map view is fired . New zoom/pan will not lead to new GetFeatures. If "Cache Features" is unchecked QGIS should be in a live mode and make a new GetFeature request after every zoom/pan. This may be simplified, I am remembering that if the new BBOX is totally inside the previous one then new GetFeature is not done because it is really not needed.

Your description may still be right because I have a feeling that since QGIS 1.8 the behaviour with Cache features has been somewhat unstable. What do you exactly mean with "older versions"?

#3 Updated by zicke - over 4 years ago

It works with QGIS 1.8.

#4 Updated by Jeremy Palmer about 4 years ago

  • Status changed from Open to Closed

This is now fixed in master 188625c

closing

Also available in: Atom PDF