Bug report #13391

GeoJSON not displayed correctly

Added by Joachim Ungar almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.8.1 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21443

Description

All features in the attached GeoJSON file (generated with fiona) are squares but when loading into QGIS 2.8.1, some of them are distorted and displayed as rectangles. Zooming in or out showed the same distortions.

The Shapefile version is displayed correctly. To be sure the GeoJSON file is fine, I also wrote a short script asserting that the features heights and widths are equal.

Interestingly, after loading the Shapefile, the originally loaded GeoJSON was then displayed correctly and in alignment to the control Shapefile.

To reproduce:
  • load GeoJSON
  • highlight one (non-square) rectangle via identify before loading Shapefile
  • "Save as" Shapefile and load to map, on top of GeoJSON
  • highlighted geometry is not aligned to Shapefile geometry
  • turn off Shapefile
  • GeoJSON now displayed correctly

Cheers

5.geojson (439 KB) Joachim Ungar, 2015-09-21 09:30 AM

qgis_geojson.png - Screenshot (89.1 KB) Joachim Ungar, 2015-09-22 04:50 AM


Related issues

Duplicates QGIS Application - Bug report #11587: all coordinates truncated to integer values when system h... Closed 2014-11-06

History

#1 Updated by Jukka Rahkonen almost 5 years ago

I can't reproduce with QGIS 2.10.1. Could you also have a try this version?

#2 Updated by Joachim Ungar almost 5 years ago

I'm using the ubuntugis-unstable repo where only 2.8.1 is available.

Maybe the issue was already resolved for 2.10. I'll have an eye open for this when ubuntugis updates to 2.10 and come back with more information.

Thanks!

#3 Updated by Jürgen Fischer almost 5 years ago

Joachim Ungar wrote:

I'm using the ubuntugis-unstable repo where only 2.8.1 is available.
Maybe the issue was already resolved for 2.10. I'll have an eye open for this when ubuntugis updates to 2.10 and come back with more information.

Use our ubuntugis repositories - they have 2.8.3 and 2.10.1 (see http://qgis.org/de/site/forusers/alldownloads.html#debian-ubuntu)

#4 Updated by Joachim Ungar almost 5 years ago

Thanks - however, the issue remains after the update (see screenshot).

#5 Updated by Jukka Rahkonen almost 5 years ago

I can't see anything like that on Windows. Does turning OTF off change anything?

#6 Updated by Saber Razmjooei almost 5 years ago

  • Status changed from Open to Closed

Checked in QGIS and all works fine. Problem with the OTF.

#7 Updated by Martin Weis over 4 years ago

This is a duplicate of #11587

Also available in: Atom PDF