Bug report #13343

Rendering long segments produces artefacts

Added by andskog - over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:2.10.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21396

Description

When rendering long line geometries and zooming in, the line can render incorrectly with segments crossing the canvas at random places. If I split the line to smaller segments, it renders correctly. Data and screenshots of the buggy rendering attached.

bug.png - rendering bug (138 KB) andskog -, 2015-09-25 01:35 AM

Associated revisions

Revision 08185c9a
Added by Jürgen Fischer over 4 years ago

render polygons with outline using drawPath (fixes #13343)

Revision 721856a3
Added by Jürgen Fischer over 4 years ago

render polygons with outline using drawPath (fixes #13343)

(cherry picked from commit 08185c9af47dcf113c0cb95faa858ec48e48dab2)

Revision c0156fc4
Added by Jürgen Fischer over 4 years ago

render polygons with outline using drawPath (fixes #13343)

(cherry picked from commit 08185c9af47dcf113c0cb95faa858ec48e48dab2)

Revision c6460a3d
Added by Jürgen Fischer over 4 years ago

render polylines with drawPath too (followup 08185c9; fixes #13343)

Revision dbe30f9c
Added by Jürgen Fischer over 4 years ago

render polylines with drawPath too (followup 08185c9; fixes #13343)

(cherry picked from commit c6460a3d7de23e655c5fa68309b8224555b0b77f)

History

#1 Updated by Saber Razmjooei over 4 years ago

  • Status changed from Open to Feedback

No attachements!

#2 Updated by andskog - over 4 years ago

#3 Updated by andskog - over 4 years ago

This issue should probably be tested on several computers, because the bug doesn't occur on all. I've tried on two W7 computers, one produces the bug, the other doesn't..

#4 Updated by Nyall Dawson over 4 years ago

Andskog - can you share some data and a project which demonstrates this?

#5 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF