Bug report #13223

Multiple dataframes export issue from composer - two images of same area, on export only one is rendered in both

Added by Nick Jones almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:21284

Description

Replicated the issue on OSX, and windows with 2.8.2. Try adding imagery from two different dates over the same area (before and after images), unselect the newer image in main QGIS table of contents, then in composer draw the box for data to show (old image is shown). Draw another box with old image turned off, but new one turned on - new image is shown on map. Try to export as jpeg or PDF, both dataframes will contain same image. On export only one image is rendered for both dataframes.

History

#1 Updated by Nick Jones almost 5 years ago

Uninstalled 2.8.2, updated to 2.10.1 - issue still exists - no change in version.

#2 Updated by Nyall Dawson almost 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

This is expected behaviour. A couple of things to note:

1. Map content in composer only updates when you click the "refresh" button (on either the toolbar or an individual map item's properties panel). That's why it looks like the first map has kept the original layer.

2. To actually LOCK the layers for a map, you need to setup your main map canvas as desired, then click the "Lock layers for map item" checkbox under the composer map item properties panel.

Also available in: Atom PDF