Bug report #1315

"Actions" in qgis do not work on MS windows

Added by rap - about 12 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Gavin Macaulay -
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11375

Description

qGIS (0.11/windows) crashes if you want to use actions (e. g. to link images or websites)

This problem only occure on the windows version, on ubuntu actions seems to work properly.

Original Task: link photos to point shape files using "actions".

An action is defined: calling "firefox" as action
The Identify Feature is used to open the identify window
A click on the action is used to define the action...

result: qgis crashes

Regards,
Gerhard

qgiscrash_actions.pdf - screen pictures of the use of action - and its crash (250 KB) rap -, 2008-09-15 02:51 AM

History

#1 Updated by Paolo Cavallini about 12 years ago

Any additional info? It works for me, at least in 1.0 preview[1-2]

#2 Updated by Mike Taves almost 12 years ago

I'm pretty sure this is fixed in version 1.0 and this ticket can be closed. See also #1203 which I just reopened.

#3 Updated by Paolo Cavallini almost 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

#4 Updated by doktoreas - over 11 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

I got this trouble using 1.0.1; clicking an action make Qgis crash.
Using windows vista 64bit

Thanks
Luca

#5 Updated by Mike Taves over 11 years ago

I'm still certain that this issue (in regards to not working on Windows) was fixed for version 1.x. You might have this confused with another bug #1203, which is entirely possible.

But, to be sure, try this:
1. Add a layer to a QGIS project, and go to the properties
1. In the "Actions" tab, make a new action
1. Set name to: Search this
1. I'll assume you have Firefox installed, so set action to: "C:\\Program Files\\Mozilla Firefox\\firefox.exe" http://www.google.com/search?q=%name
1. Edit "%name" to grab a field name from your feature layer into the query, such as a single-word name or numeric value. There is an "Insert field" tool to help you out.
1. Don't select capture, since this is bug #1203, and it doesn't make sense for this action. Keep it unselected!
1. Click Insert action, and OK
1. Save the project (in case the crash happens)
1. Use you identify tool and click on a feature item
1. Click the action ... did it crash or search the %name ?

Now, if you want to recreate #1203, modify the above to capture output, and use a command that does not exist (e.g., modify firefox.exe to nothing.exe) and crash!

#6 Updated by Paolo Cavallini over 11 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

Comments by mwtoews seem convincing. Closing the bug. If inappropriate, please reopen it.

#7 Updated by Anonymous over 11 years ago

Milestone Version 1.0.1 deleted

Also available in: Atom PDF