Bug report #1203

QGIS segfaults when an Action with capture output has an invalid path to executable is called

Added by Steven Mizuno about 11 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11263

Description

Steps to show the problem:

1. create an Action in Layer Properties, specifying a program that doesn't exist - xyz, for example.

2. set Capture output (this is due to another bug already reported)

3. use Identify on the layer, pick an object

4. click on the Action created in step 1

5. QGIS quits - segfault

This happens on Windows and Linux; can't test Mac.

Versions at least back to 0.9.0 have this problem.

r8952; Qt 4.3.3 & 4.4.0

Associated revisions

Revision bf354814
Added by Jürgen Fischer over 10 years ago

fix #1203

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision d3a38b04
Added by Jürgen Fischer over 10 years ago

fix #1203

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by gjm - about 11 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Fixed by applying patch in #989.

#2 Updated by Mike Taves over 10 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Feedback

I have this issue with my Windows XP version of QGIS 1.0.0.

According to my "About" dialog, I have: "QGIS version 1.0.0-Kore built against code revision unknown", which I obtained from OSGeo4W yesterday. Sorry, I can't confirm this on any other platform.

#3 Updated by Mike Taves over 10 years ago

Note that I only have this crashing behaviour with Capture output enabled.

With Capture output disabled, everything works as expected (including error message if a command is not found).

#4 Updated by Mike Taves over 10 years ago

I don't see the other bug that reports the capture output bug (so I modified the summary), but this report is still valid (I have 1.1 - trunk for WinXP via OSGeo4W).

#5 Updated by Jürgen Fischer over 10 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

should be fixed with d3a38b04 (SVN r10534)

#6 Updated by Anonymous about 10 years ago

Milestone Version 1.1.0 deleted

Also available in: Atom PDF