Feature request #989

Action with Capture output disabled appears to do nothing

Added by Steven Mizuno over 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:Map Canvas
Pull Request or Patch supplied: Resolution:fixed
Easy fix?:No Copied to github as #:11049

Description

Action with Capture output disabled appears to do nothing when activated (Linux and Windows; don't know about Mac).

1. set up an Action to start Firefox, for example (doesn't matter what program is used); don't enable Capture output
2. Identify an object on the canvas, then click the action item in the Identify Results dialog - no window for the program appears.

If Capture output is enabled, then the dialog to show the results of the program appears and the program window appears as expected.

This used to work on 0.8.1

patch_for_bug_989.txt Magnifier (1.33 KB) Steven Mizuno, 2008-03-21 06:01 PM

History

#1 Updated by Steven Mizuno over 12 years ago

I am submitting a patch to fix this problem. This is the cause: the process is started, then immediately killed by die() if the process is not captured.

The details:

1.merged the two

if (capture)

code blocks where the process is started for capturing

2. used QProcess::startDetached() to start the non-captured process

3. on failure to start the non-captured process a message box is raised to inform the user

I have tested this on Linux and Windows XP.

#2 Updated by gjm - about 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Applied in 1b378f63 (SVN r8990). Thanks.

#3 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF