Bug report #13112

"std::bad_alloc" when styling a singleband pseudocolor on a raster

Added by Etienne Trimaille almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Rasters
Affected QGIS version:2.10.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21177

Description

When styling a raster using a Singleband Pseudocolor, I choose Continuous and click Classify.
Then I got "std::bad_alloc". It's impossible to get the custom color map.

Associated revisions

Revision 688ac161
Added by Nyall Dawson almost 5 years ago

Fix bad alloc when styling raster with random color ramp (fix #13112)

Revision a8ad5c1f
Added by Nyall Dawson almost 5 years ago

Fix bad alloc when styling raster with random color ramp (fix #13112)

(cherry-picked from 688ac1610e5b47fa3116875c463ba9fd2a026200)

Revision 55022226
Added by Nyall Dawson almost 5 years ago

Fix bad alloc when styling raster with random color ramp (fix #13112)

(cherry-picked from 688ac1610e5b47fa3116875c463ba9fd2a026200)

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Target version deleted (Version 2.10)
  • Priority changed from Severe/Regression to High
  • Status changed from Open to Feedback

Hi, confirmed but not a regression, at least not from a recent qgis version. And it happens only when trying to use "random colors", so anyway while annoying does not seems a huge issue (does a random color palette have any meaning for styling a raster?).

#2 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF