Bug report #13092

Voronoi polygons wrong if adding a 1 m buffer

Added by Paolo Cavallini about 5 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21159

Description

When running the exercise john snow from the training manual, the voronoi polygons from QGIS algs are calculated correctly whn using buffer 0, but are wrong if a buffer = 1 m is added. See attached image (a polygon with two points, an one empty)

voronoi.png (19.9 KB) Paolo Cavallini, 2015-07-08 07:26 AM

History

#1 Updated by Andrew Bevitt almost 5 years ago

This looks like a duplicate of #8002

#2 Updated by Paolo Cavallini almost 5 years ago

The phenomenon is different; unsure if the underlying problem is the same.

#3 Updated by Andrew Bevitt almost 5 years ago

If it is a duplicate then the empty polygon is partially covered by the polygon which appears to have two points. Try changing the layer transparency to see if this is the case.

#4 Updated by Paolo Cavallini almost 5 years ago

It is not.
Thanks.

#5 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

The voronoi result with buffer with the "pumps" vector from the training manual dataset has indeed overlapping polygons, and indeed the patch proposed in #8002 solves the issue, at least the one described in this ticket.

#6 Updated by Håvard Tveite almost 2 years ago

The errors caused by using buffer (correct polygons when not using buffer - incorrect when using buffer) still existed in 3.2.
The buffer error should be fixed with a recently merged pull request (https://github.com/qgis/QGIS/pull/7469).

#7 Updated by Paolo Cavallini almost 2 years ago

This is apparently a duplicate. Please add your comment to the other ticket. Thanks.

Also available in: Atom PDF