Bug report #13041

Processing Toolbox Doesn't Pick Up New Database Connections

Added by Spencer Gardner about 4 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21116

Description

The processing toolbox seems to build its cache of available PostGIS connections when QGIS is loaded and the cache is not updated when I create a new database connection.

Steps to reproduce:
  1. Open QGIS
  2. Create new PostGIS connection
  3. Open the "Import into PostGIS" dialog
  4. Check the dropdown for PostGIS connections

What happens:
The new database connection is not shown in the list.

What should happen:
The new connection should appear in the list.

I've tested using QGIS 2.8.2 on a Windows 7 machine and an Ubuntu 15.04 machine.


Related issues

Duplicated by QGIS Application - Bug report #13344: Processing Import into PostGIS: list of connection does n... Closed 2015-09-11

History

#1 Updated by Jürgen Fischer about 4 years ago

  • Tracker changed from Support to Bug report
  • Project changed from QGIS Redmine (QGIS bug tracker) to QGIS Application
  • Affected QGIS version set to 2.8.2
  • Crashes QGIS or corrupts data set to No

#2 Updated by Jürgen Fischer about 4 years ago

  • Category set to Processing/Core

#3 Updated by Spencer Gardner almost 4 years ago

It just occurred to me that the likely cause is that the combo box that holds DB connections appears to be generated when the Processing plugin is first initialized, even though a user may make changes before actually opening the dialog. Is there some way to prevent instantiation of the dialog until it is actually called by the user via the GUI?

#4 Updated by Alexander Bruy over 3 years ago

  • Tag deleted (processing)

List of available connections populated during Processing algorithm initialization, that's why changes introduces after instatiating algorithm object are not available.

#6 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to No
  • Easy fix? set to No

#7 Updated by Nyall Dawson over 1 year ago

  • Resolution set to fixed/implemented
  • Description updated (diff)
  • Status changed from Open to Closed

Fixed since PR was merged

Also available in: Atom PDF