Bug report #12987

Values not updating properly when editing attribute table

Added by Frank Sokolic about 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Attribute table
Affected QGIS version:2.8.2 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:21065

Description

This happens when editing shapefile attribute tables:
  1. Open an attribute table
  2. Enable editing
  3. Edit values in the table by typing directly into the cells
  4. The new values appear in the attribute table
  5. Save the edits
  6. Close the table and open it again
  7. The old values reappear in the table
  8. Remove the layer from QGIS and reload the shapefile
  9. The new values now appear in the attribute table

History

#1 Updated by Frank Sokolic about 5 years ago

I have also tested the Field Calculator and tried to add polygon centroids using the $x and $y functions. These just generate nulls. However, if I type values manually into the respective X and Y fields then I get the behaviour described above. The X and Y fields are defined as type real, width 10, precision 6. The CRS for both the layer and project is set to EPSG 4326 and OTF is off.

#2 Updated by Giovanni Manghi about 5 years ago

Frank Sokolic wrote:

I have also tested the Field Calculator and tried to add polygon centroids using the $x and $y functions. These just generate nulls. However, if I type values manually into the respective X and Y fields then I get the behaviour described above. The X and Y fields are defined as type real, width 10, precision 6. The CRS for both the layer and project is set to EPSG 4326 and OTF is off.

$x and $y do not work for polygons, only points.

#3 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback
  • Priority changed from High to Normal
  • Target version deleted (Version 2.10)

I cannot confirm here (ubuntu too) on both 2.8.2 and master.

#4 Updated by Pedro Venâncio about 5 years ago

Hi,

I confirm this on 2.10 and master, on windows (OSGeo4W 64bits). It happens both with Field Calculator and normal attribute table edit.

Please see the screencast: https://dl.dropboxusercontent.com/u/5772257/qgis/qgis_210_master_attribute_table.avi

I think this could be a blocker.

#5 Updated by Nyall Dawson about 5 years ago

Possibly related to cc13c57. That fix only applies to 2.10 though, not 2.8.

#6 Updated by Jürgen Fischer about 5 years ago

  • Priority changed from Normal to Severe/Regression

#7 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Feedback to Open

#8 Updated by Giuseppe Sucameli almost 5 years ago

Unable to reproduce it on Ubuntu 14.04 with current master ce6264065de

#9 Updated by Frank Sokolic almost 5 years ago

I no longer get this error on Master either, Ubuntu 15.04.

#10 Updated by Jürgen Fischer almost 5 years ago

  • Priority changed from Severe/Regression to High

not a blocker for releases.

#11 Updated by Pedro Venâncio almost 5 years ago

I also can not reproduce this problem on master anymore (tested on OSGeo4W 32 and 64bits).

#12 Updated by Jürgen Fischer over 4 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

probably fixed.

Also available in: Atom PDF