Bug report #12842

Merge selected features drops data silently

Added by Paolo Cavallini over 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20937

Description

If one select and operation on merging data from fatures (e.g. average) that returs a decimal number, whereas the column type is int, the data are neither rouded nor truncated, but dropped without warning the user. Same form Merge attributes.

Associated revisions

Revision 099a40bd
Added by Nyall Dawson about 4 years ago

Fix merge attributes/features tool resets values to null for int fields

Also add a warning if merged attribute value is not compatible with
field type.

Fix #12842

Revision d8303a76
Added by Jürgen Fischer about 4 years ago

pass through default values when merging features (followup 099a40b, refs #12842)

Revision c5762816
Added by Nyall Dawson about 4 years ago

Fix merge attributes/features tool resets values to null for int fields

Also add a warning if merged attribute value is not compatible with
field type.

Fix #12842

(cherry-picked from 099a40bdf2a59f87e28b9c6664c6b9da6fd927b4)

History

#1 Updated by Nyall Dawson about 4 years ago

  • Status changed from Open to Feedback

I can't reproduce this. Can you please post steps to trigger this issue?

#2 Updated by Nyall Dawson about 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF