Bug report #12793

Minidump when adding a layer (vector, raster, etc.)

Added by Oscar Alvarez over 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:20890

Description

QGIS creates a minidump file, and crashes when I add a layer (whether a new or existing project), regardless of layer type.
This happens after clicking on the Browse button.

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to Feedback

try rename/remove (make a backup first) the .qgis2 folder, restart qgis and try again.

#2 Updated by Oscar Alvarez over 5 years ago

I made a backup of the original .qgis2 folder but still the same issue.
I also did a fresh install to the most recent QGIS version and the same minidump happens.

#3 Updated by Saber Razmjooei over 5 years ago

Could you specify, platform, QGIS version, installation method, etc?

#4 Updated by Giovanni Manghi over 5 years ago

Of course this seems like very much a local issue. Please test also other installations, on other machines, with the same data.

#5 Updated by Oscar Alvarez over 5 years ago

Platform: Win7 SP1 64-bit
QGIS 2.8.2 Wien
I downloaded the fresh install via the QGIS website https://www.qgis.org/en/site/forusers/download.html
It's strange that I get the minidump via add vector/raster layer instead of the program shutdown which was documented in another ticket.

If this is a local issue, is there anything that I should look out for, say antivirus or icloud settings?
Will check later on my Mac if this will also be an issue.

#6 Updated by Oscar Alvarez over 5 years ago

Had installed QGIS on my Macbook Pro, with OS X Yosemite.
Did all the instructions on the KyngChaos wiki.
No issues noticed when trying to open layers.

So is there anything that I should look out for on my Windows installation?

#7 Updated by Saber Razmjooei over 5 years ago

Are you trying to access a network drive for adding a vector/raster layer? Or is it on a local drive?

#8 Updated by Ravic Nijbroek over 5 years ago

Hi Oscar, have you found a solution yet? I'm a new QGIS user and have the same problem. I can add a file (vector, raster, etc) by browsing to the file and double clicking. However, if I use the Add Vector (or Raster) button, then click on browse, I get the same minidump error and crash. I also use Windows 7 on a 64bit OS and just downloaded and installed v2.8.2. Changing the .qgis2 folder did not help.

#9 Updated by Saber Razmjooei over 5 years ago

Oscar and Ravic:
Do you use Anti Virus?

#10 Updated by Ravic Nijbroek over 5 years ago

I use ESET antivirus software on my work laptop.
Since you asked about this, I turned it off temporarily and restarted QGIS. Still get the same error when I click on browse:

minidump written to C:\\Users\\RNIJBRR~1\\AppData\\Local\\Temp\\qgis-20150604-120452-11284-11996-1b929ef.dmp

#11 Updated by Andreas Neumann over 5 years ago

Hi,

I just tried adding layers from the browser on Win7, 64bit. I tested versions 2.8.2, 2.8 nightly and master. All work fine without crashes.

Can you please test 2.8 nightly and/or master and see if the issue still exists?

Thanks,
Andreas

#12 Updated by Frank Sokolic over 5 years ago

  • Target version set to Version 2.10

Not sure if it is the same error but I get a crash and minidump every time I try to add a layer with QGIS 2.10.1 Pisa (standalone installation) on Win7 SP1 64-bit.

On further inspection this crash occurs with any operation that tries to open the File dialogue. All of the following cause a crash:
  • Project > Open
  • Project > Save
  • Project > Save As
  • Add vector layer > Browse
  • Add raster layer
  • Any of the Vector > Geoprocessing tools when clicking Browse

Could this be something specific to Win7 SP1 64-bit?

Dragging and dropping layers from the Browser dock works fine.

The file dialogue in the standalone QGIS Browser > New Shapefile > Ok > Save layer as... works fine.

#13 Updated by Giovanni Manghi about 5 years ago

  • Target version deleted (Version 2.10)

#14 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

closing for lack of feedback.

Also available in: Atom PDF