Bug report #12762

Map polluted by circles ?!

Added by Sandro Santilli almost 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Symbology
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20861

Description

This is a pretty weird bug I'm facing.
My map contains circles that move around whenever I zoom.
The circles seem to be associated to the features on the map as if it was a decoration.
The point layer has these circles drawn somewhere on the bottom-right so that the requested marker (simple marker) falls outside of the circle.
The line layer (a single line) has a single circle drawn, centered near the centroid (but sometimes more on a side).
The circle size is independent from map zoom.

The same behavior happens with 2.8.2 and with master.

I'm attaching a short screencast taken with master

circles.ogv - screencast (639 KB) Sandro Santilli, 2015-05-18 01:09 AM

issue12762.qgs - simplified project file (still needs external data) (22.3 KB) Sandro Santilli, 2015-05-18 01:24 AM


Related issues

Related to QGIS Application - Bug report #12618: 2.8.1 circles which don't seem to be on any layer Closed 2015-04-21

History

#1 Updated by Sandro Santilli almost 5 years ago

#2 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Open to Closed
  • Resolution set to wontfix

This happens if you save a project in master and then open in 2.8. You can fix it by turning off diagrams for the layer in 2.8. Otherwise it's just due to a change in the project file format required to allow switching off diagrams without losing their settings.

#3 Updated by Sandro Santilli almost 5 years ago

But I never enabled diagrams in any of the two versions, how did they get enabled ?

#4 Updated by Sandro Santilli over 4 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (wontfix)
  • Assignee set to Nyall Dawson

Was this actually fixed by Nyall via this c449b95dcb4c37fbc687b4286c68d59758c28be3 ?
Re-opening for confirmation (was previously closed as "wont-fix")

#5 Updated by Nyall Dawson over 4 years ago

  • Status changed from Reopened to Closed

Should be fixed now - can you reopen if you still see this after that commit?

#6 Updated by Sandro Santilli over 4 years ago

Seems to be fine now. Could you please set TargetVersion to the earliest version this was fixed in ?
It sounds like it would be 2.8.3, right ?
Giovanni: there's no 2.8.3 yet in the TargetVersion list, could you add it ?

Also available in: Atom PDF