Bug report #12618

2.8.1 circles which don't seem to be on any layer

Added by Mark Percival over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Canvas
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No

Description

I've got some strange things happening with 2.8.1-Wien in that, I open a project and I get a load of circles which don't seem to be on any layer - I also get this in the 2.9.0-Master (CR 213a22b) version but with a different set of layers. I've been through a process of checking layers (removing, changing styles etc.) until I found it was being caused by Image fills to polygons (I believe so anyway) - this was common in 2 different projects, with different layers. Once the circles appear you can't get rid of them by changing the style and they are not consistent as to where they appear - they will also show in composer but not in a map, or map alone or both!
I have attached a screen-shot to illustrate.

I've recreated both projects from scratch (without image fills) and the problem hasn't re-occured.

CircleIssue.jpg - Screen-shot (300 KB) Mark Percival, 04/21/2015 06:37 AM


Related issues

Related to QGIS Application - Bug report #12762: Map polluted by circles ?! Closed 05/18/2015

History

#1 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

Looks to me like you have empty diagrams enabled for a layer - can you confirm?

#2 Updated by Giovanni Manghi over 2 years ago

  • Category set to Map Canvas

Nyall Dawson wrote:

Looks to me like you have empty diagrams enabled for a layer - can you confirm?

Hi Nyall,

I have been bitten a few days ago by this bug(?) and I'm pretty sure it was not caused by empty diagrams because I have seen this circles in a project where I have never used diagrams. In my case the circles where visible once the project (done in qgis 2.9) was published via QGIS server 2.8. After updating the server to 2.9 the circles stopped to show. Unlike the above report I also not used image fills but only solid colors with a bit of transparency.

#3 Updated by Nyall Dawson over 2 years ago

I'm 99% confident it's caused by empty diagrams - can you double check to help me confirm?

#4 Updated by Giovanni Manghi over 2 years ago

Nyall Dawson wrote:

I'm 99% confident it's caused by empty diagrams - can you double check to help me confirm?

Hi Nyall,
the way this circles showed seems to make sense to be something related to diagrams, I have anyway checked my project and the diagram options is disabled and there are no diagrams defined, empty or with any defined options.

#5 Updated by cgsbob - over 2 years ago

Hi Nyall,
the way this circles showed seems to make sense to be something related to diagrams, I have anyway checked my project and the diagram options is disabled and there are no diagrams defined, empty or with any defined options.

I had an old project that showed the circles after saving it QGIS 2.8.1. I wasn't using diagrams, but the diagram checkbox was checked after saving the project. Unchecking diagram mode fixed it for me.

#6 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF