Bug report #12757

Zoom out crashes QGIS

Added by Paolo Cavallini over 4 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:2.8.2 Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20856

Description

Pretty simple to replicate.
Thanks Tim for letting us know.

Associated revisions

Revision 1bf98446
Added by Sandro Santilli over 4 years ago

Do not allow invalid map settings (fixes #12757)

History

#1 Updated by Richard Duivenvoorde over 4 years ago

easy replicatable by using the scrollwheel of a mouse: just keep zooming out by running the wheel...

#2 Updated by Sandro Santilli over 4 years ago

Confirmed. Doesn't require anything being loaded on the map.
The problem is an overflow on scale values. Should we limit the min/max scales somehow ?
Refusing to change parameters if resulting matrix is not invertible, maybe ?

#4 Updated by Saber Razmjooei over 4 years ago

  • Status changed from Open to Feedback

Can't reproduce in master.

#5 Updated by Sandro Santilli over 4 years ago

Saber, did you keep zooming out ? More and more ?

#6 Updated by Saber Razmjooei over 4 years ago

Sandro, for the past 3 minutes...now changing to left hand! :)

#7 Updated by Saber Razmjooei over 4 years ago

  • Status changed from Feedback to Open
  • Operating System set to Linux

The bug appears to be platform specific and does not affect Windows installation.
Here is what I get under Ubuntu:
qgis: /tmp/buildd/qgis-2.8.2+20trusty/src/core/qgsmaptopixel.cpp:125: QgsPoint QgsMapToPixel::toMapPoint(double, double) const: Assertion `invertible' failed.
Aborted

#8 Updated by Paolo Cavallini over 4 years ago

This has been fixed during the HF; I do not know if backported

#9 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Paolo Cavallini wrote:

This has been fixed during the HF; I do not know if backported

please reopen if necessary.

#10 Updated by Nyall Dawson over 4 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (fixed/implemented)

It's not fixed yet - there's a PR with a work in progress fix at https://github.com/qgis/QGIS/pull/2044, but it's not merged yet.

#11 Updated by Sandro Santilli over 4 years ago

  • Status changed from Reopened to Closed

#12 Updated by Bas Couwenberg about 4 years ago

  • Status changed from Closed to Reopened

This issue has also been reported for QGIS 2.8.4 in Debian Bug #809063, I've confirmed it with 2.8.5 too.

Can changeset 1bf9844652ad2b92ab2da2a37ebf941257416403 be backported to QGIS 2.8 LTR?

In #14008 the same "Assertion `invertible' failed." error is reported to affect 2.8.4, which I suspect is fixed by the backport too.

#13 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#14 Updated by Nyall Dawson over 2 years ago

  • Status changed from Reopened to Closed
  • Description updated (diff)

This can be safely closed - 2.8 is no longer supported and it's fixed for 2.14/2.18/3.x

#15 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF