Bug report #12582

buildvrt causes QGIS to crash

Added by Paolo Cavallini over 5 years ago. Updated over 3 years ago.

Status:Rejected
Priority:Normal
Assignee:-
Category:Processing/GDAL
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:20707

Description

Create a vrt in a project with many files, then zoom results in a crash. No crash when creating on a fresh project. Verified in Debian Sid, Ubuntu, and various Windows.

History

#1 Updated by Alexander Bruy over 4 years ago

If VRT file created from command line and then opened in QGIS and zoomed does it crash QGIS too? Looks like issue not with GDALTools but with handling huge VRT files.

#2 Updated by Paolo Cavallini over 4 years ago

It is not the size of VRT as much as the number of files in the project. It may well be due to concurrency in read operations.
Difficult to reproduce because of this.

#3 Updated by Giovanni Manghi over 3 years ago

  • Category changed from GDAL Tools to Processing/GDAL

#4 Updated by Alexander Bruy over 3 years ago

  • Resolution set to invalid
  • Status changed from Open to Rejected

For me it looks like not GDALTools/Processing issue, as tool produced correct output. Crashes when zooming related to QGIS core, and another ticket should be opened if this still true on master.

Also available in: Atom PDF