Bug report #12534

Basic Statistics shows 'No features selected' when too many features are selected.

Added by Samuel Ingarfield over 5 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:20677

Description

Using the Basic Statistics tool (Vector->Analysis Tools->Basic statistics), if I select too many features (say 13000), then the tool returns with a message saying that no features are selected. If I lower the number of features selected (say 6400) then it works. A less confusing error message or removal of the limit would be preferable.

History

#1 Updated by Giovanni Manghi over 5 years ago

  • OS version deleted (7 x86_64)
  • Category set to 44
  • Operating System deleted (Win)

confirmed on Linux too (qgis master).

#2 Updated by Alexander Bruy over 4 years ago

  • Status changed from Open to Feedback

Works fine for me, tested on layer with 18469 features. No errors, statistics calculated and reported.

#3 Updated by Nyall Dawson over 4 years ago

I think a fix I made in 2.12 probably also fixed this - was this bug encountered when using a PostGIS table?

#4 Updated by Nyall Dawson about 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

Closed due to lack of feedback

#5 Updated by Giovanni Manghi about 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF