Bug report #12530

Basins close to bounding box are not calculated

Added by Paolo Cavallini over 5 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/SAGA
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:20674

Description

Compare the attached image to the exercise in the training manual: three peripheral basins are not calculated.

basin.png (49 KB) Paolo Cavallini, 2015-04-08 09:14 AM

History

#1 Updated by Alexander Bruy almost 4 years ago

Looks like SAGA issue

#2 Updated by Paolo Cavallini almost 4 years ago

Possibly - cannot test now because of saga API break. However at first it worked, as shown by the images on the training manual.

#3 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#4 Updated by Victor Olaya about 3 years ago

This is a SAGA thing, and not really an issue, but an improvement. Basins that "touch" the boundary of the layer are affected by the so-called "edge contamination", since you dont know what is upstream, and catchment area values (from where rivers and basins are computed) are not sound. So looks like SAGA decided to not add those basins.

In any case, i suggest updating the exercise screenshots, and to not consider this a bug

#5 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback

#6 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to wontfix
  • Status changed from Feedback to Closed

Also available in: Atom PDF