Bug report #12362

Heatmap renderer not working when layer is reprojected

Added by Jason Fairbrother over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20537

Description

The new live heatmap renderer (Properties > Style from a point layer) is great, however I'm having one issue with it.

When I try to have one layer with the heatmap, and add another layer from OpenLayers (such as a Google or Stamen map) the heatmap disappears. I've tried playing around with CRSs, but to no avail. I don't think it's a CRS problem, as when I choose "Zoom to Layer", it stays in the correct position.

When I turn the point layer from an invisible heatmap back to a simple point layer, the points will re-appear in the correct position.

I'm not sure if this is in anyway related to the other heatmap problem (using the plugin) that has already been reported in 2.8.

Cheers.

Associated revisions

Revision 23d6b66a
Added by Nyall Dawson over 5 years ago

Fix heatmap renderer not working for reprojected layers (fix #12362)

Revision e17ec09e
Added by Nyall Dawson over 5 years ago

Fix heatmap renderer not working for reprojected layers (fix #12362)

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Affected QGIS version changed from 2.8.1 to master
  • Category set to Symbology
  • Subject changed from Live heatmap renderer (not plugin) not working with OpenLayers plugin maps to Heatmap renderer not working when layer is reprojected

The problem is general and not only related to the OL plugin. If the layer with the heatmap symbology is reprojected then it does not show.

I have the feeling there was already a ticket about this but can't find it, maybe I'm wrong.

#2 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Closed

#3 Updated by Paolo Cavallini over 5 years ago

Better backport it?

Also available in: Atom PDF