Bug report #12227

QGis Server - WFS - GeoJSON and escaping backslash

Added by Jeffrey Bostoen over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.6.1 Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20415

Description

I had a shapefile I made available as a WFS-service with QGis Server.

OpenLayers 3 kept giving me an error. Turns out I was using a path in the shapefile, D:\\location-on-disk , that was giving us some trouble.
It seems like the JSON spec would require that it is properly escaped.

So the GeoJSON contains something like "myProperty" : "D:\\location-on-disk" instead of "myProperty" : "D:\\\\location-on-disk".

Associated revisions

Revision a449af25
Added by Alexander Bruy over 5 years ago

[processing] fix typo in the algorithm name (fix #12227)

Revision 8ffa4acf
Added by Alexander Bruy over 5 years ago

[processing] fix typo in the algorithm name (fix #12227)

History

#1 Updated by Alexander Bruy over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF