Bug report #12079

Identify highlight color does not take alpha channel into account

Added by Regis Haubourg over 4 years ago. Updated 11 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20275

Description

Hi,
when setting a custom color for highlighting identified features, alpha channel / transparency is not applied.
That would be nice to let a user see what's under those borders, and that would be more consistent with color picker UI.
Cheers
Régis

History

#1 Updated by Paolo Cavallini over 4 years ago

  • Subject changed from Identify highlight color does not take alpha channel into acount to Identify highlight color does not take alpha channel into account

#2 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Regis Haubourg over 1 year ago

  • Resolution set to fixed/implemented
  • Description updated (diff)

still true in master, borders and lines are masked by a non transparent rubberband, even if a transparency is applied to it in the general options.
This does work for polygon fill.

#4 Updated by Regis Haubourg over 1 year ago

  • Affected QGIS version changed from 2.6.0 to 3.0.0

#5 Updated by Giovanni Manghi over 1 year ago

  • Resolution deleted (fixed/implemented)

#6 Updated by Regis Haubourg 11 months ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Also available in: Atom PDF