Bug report #12006

Value map table gets corrupted after chaging the edit widget to another one

Added by Giovanni Manghi almost 6 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Edit widget
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20209

Description

Until 2.2 if a user used a value map and then unselected this widget to use another, the value map table got lost, so in case the value map widget was selected again it was necessary to create/import it again. Not very handy, but it was a known behavior.

Since then the user can apparently unselected the value map widget, and then select it again and see the previously created table, but instead the table is filled with strange things, see attached image

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Category changed from Vectors to Edit widget

#2 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 2.8 to Version 2.8.2

#3 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 2.8.2 to Version 2.10

#4 Updated by Giovanni Manghi about 5 years ago

  • Target version deleted (Version 2.10)

#5 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#6 Updated by Nyall Dawson almost 3 years ago

  • Resolution set to fixed/implemented
  • Description updated (diff)
  • Status changed from Open to Closed

Not an issue on 3.0 master

Also available in: Atom PDF