Bug report #11974

Change default raster properties 'min/max values' settings

Added by Jens Kiesel almost 5 years ago. Updated 8 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Rasters
Affected QGIS version:2.18.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20181

Description

The 'Layer Properties > Style > Load min/max values > Accuracy' setting is set to 'Estimate (faster)' by default. The problem is, that this setting can cause significantly wrong calculations of the Histogram and a wrong display of cell values when using the 'Identify Features' button to query cell values. I am wondering if it is a desired behaviour that the rendering and style option settings influence the histogram computation and the 'Identify Features' query? So, I am not sure if this is a bug or only a feature request.

As a quick fix to this, I think the user should have the option to set the Accuracy to 'Actual (slower)' by default. This could be solved similar to how it is possible for 'Limits (minimum/maximum)' in 'Settings > Options > Rendering'. And in my view, the 'Actual (slower)' setting should be the default since it is more important to get a slower correct answer than a quicker wrong answer.

I assigned this ticket to Martin because of his responsibility for the Core Library and the Gui Library. Please change if necessary. Thanks for looking into this.

History

#1 Updated by Martin Dobias almost 5 years ago

  • Assignee deleted (Martin Dobias)

#2 Updated by elcuco - almost 4 years ago

  • OS version changed from 8 to Ubuntu 14.04
  • Priority changed from Normal to High
  • Operating System changed from Windows to Linux

I agree with Jens Kiesel. The user should have the option to set the Accuracy to 'Actual (slower)' by default (IMHO this should be the default, not Estimate (faster)). It could be an option next to 'Limits (minimum/maximum)' in 'Settings > Options > Rendering'. Also the default behaviour (again IMHO) should be to Minimum/maximum for the 'Limits (minimum/maximum)', because both are what one expects to be the initial reading of the raster, especially newbies or users that come from ArcGIS (in this software, Rasters have this default behaviour). Power users have the natural ability to tweak the raster to suite their needs.
Just "my two cents", thanks!

#3 Updated by Giovanni Manghi almost 3 years ago

  • OS version deleted (Ubuntu 14.04)
  • Affected QGIS version changed from 2.6.1 to 2.18.2
  • Operating System deleted (Linux)
  • Priority changed from High to Normal

see also:

#14853

this is really annoying I totally agree, but does not configure as "high".

#4 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No
  • Regression? set to No

#5 Updated by Mario Reyes about 2 years ago

elcuco - wrote:

I agree with Jens Kiesel. The user should have the option to set the Accuracy to 'Actual (slower)' by default (IMHO this should be the default, not Estimate (faster)). It could be an option next to 'Limits (minimum/maximum)' in 'Settings > Options > Rendering'. Also the default behaviour (again IMHO) should be to Minimum/maximum for the 'Limits (minimum/maximum)', because both are what one expects to be the initial reading of the raster, especially newbies or users that come from ArcGIS (in this software, Rasters have this default behaviour). Power users have the natural ability to tweak the raster to suite their needs.
Just "my two cents", thanks!

I agree with both of you. It would be very useful, specially for people coming from other GIS softwares and for novice users.

#6 Updated by Giovanni Manghi 8 months ago

  • Description updated (diff)
  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Should be fixed in QGIS 3.

Also available in: Atom PDF