Bug report #11971

MSSQL data with Z and M where Z is NULL wont display

Added by westy Vw over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/MSSQL
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20178

Description

If the Z value is NULL in a MSSQL Linestring or Point geometry, the table will load but the data will not display. Since MSSQL must have a value for Z if you have a value for M because the format is POINT (X Y Z M), it is possible to use NULL for the Z when there is an unknown value.

This happens frequently, due to the fact that MSSQL is often used with ESRI products which writes NULL for Z when Z is unknown and M is known.

Example geometry data:

POINT (1199100.2299588919 880237.32388755679 NULL 4.2200000000011642)

Associated revisions

Revision 012f322d
Added by Nathan Woodrow about 5 years ago

Fix #11971 - Fix display of MS SQL layers with z and m values

Funded by TechnoglogyOne, Australia

Revision 7878b3f7
Added by Nathan Woodrow about 5 years ago

Fix #11971 - Fix display of MS SQL layers with z and m values

Funded by TechnoglogyOne, Australia

- Backported to 2.8.3
- Cherry-picked from 012f322d96969e8d8db3514bc85bad51246c7a0d

History

#1 Updated by Jürgen Fischer over 5 years ago

  • Category set to Data Provider/MSSQL

#2 Updated by Nathan Woodrow about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF