Bug report #11968

WFS-GetFeature broken (with "caching" unchecked)

Added by Benjamin Schepers almost 5 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20175

Description

I'm using the latest QGIS 2.6.1 and don't get get the features from a WFS, when caching is unchecked in the wfs loader.
If caching was checked everything seems to work well.

Analyzing the server-site requests gave the following results from the logs:

WITH Cache-Features checked:

blabla/bla?SERVICE=WFS&REQUEST=GetCapabilities&VERSION=1.0.0
blabla/bla?SERVICE=WFS&VERSION=1.0.0&TYPENAME=test&&REQUEST=DescribeFeatureType
blabla/bla?SERVICE=WFS&VERSION=1.0.0&REQUEST=GetFeature&TYPENAME=test&SRSNAME=EPSG:25832

WITHOUT Cache-Features:

blabla/bla?SERVICE=WFS&REQUEST=GetCapabilities&VERSION=1.0.0
blabla/bla?SERVICE=WFS&VERSION=1.0.0&TYPENAME=test&BBOX=342300.2220367033733055,5702838.80950548313558102,342795.02078515768516809,5703155.46760591678321362&REQUEST=DescribeFeatureType
blabla/bla?SERVICE=WFS&VERSION=1.0.0&REQUEST=GetCapabilities&TYPENAME=test&SRSNAME=EPSG:25832&BBOX=342300.2220367033733055,5702838.80950548313558102,342795.02078515768516809,5703155.46760591678321362

GetCapabilities worked well in both scenarios; with Caching unchecked, the BBOX parameter appears (seems alright), but the REQUEST-Parameter is wrong (GetCapabilities instead of GetFeature!)
=> the QUERY-String on the clientside is composed in a wrong way, with Parameter "caching" unchecked!

Please have a look at this

Thx


Related issues

Related to QGIS Application - Bug report #13117: cached wfs not downloading new features while panning Closed 2015-07-15

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Category set to Web Services clients/WFS
  • Status changed from Open to Feedback

duplicate of #9444 ?

#2 Updated by Jukka Rahkonen almost 5 years ago

Not a duplicate. In this case client is generating invalid requests. Also the DescribeFeatureType is wrong but I suppose that the extra BBOX parameter that should not be there is just skipped by the WFS server.

#3 Updated by Benjamin Schepers almost 5 years ago

I'm using QGIS 2.6.1 for Windows; always WFS in "non-Cache-mode".

The Errors (GetCapabilities instead of GetFeature) occured while testing against a QGIS-Server, latest Debian-build from QGIS-Sources.
The same Errors while using WFS occured with a different dataset from UMN Mapserver (self-compiled 6.4.1).

Testing those Services with ArcGIS and older QGIS 2.0.1 (Windows) they worked well.
Things become stranger now: the same "buggy" Client (2.6.1) works well against a GeoServer (no Version Information nor any Server-logs, Sorry).

IMHO there seem some things to be broken on the Client-side.

#4 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Feedback to Open

#5 Updated by Giovanni Allegri over 4 years ago

I've justed on QGIS 2.8.1 and master. Both seems to request features correctly, but the bbox is disregarded (code seems commented) maybe because of some related problems not yet fixed (as Marco said on qgis-dev list)

#6 Updated by Giovanni Manghi over 4 years ago

  • Target version changed from Version 2.8 to Version 2.8.2

#7 Updated by Giovanni Manghi over 4 years ago

  • Target version changed from Version 2.8.2 to Version 2.10

#8 Updated by Benjamin Schepers over 4 years ago

The problems decribed above existed also with QGIS 2.8.x. and always GeoServer (from the same Infrastructure) automagically worked very well...

Thankfully WFS (non-Cache Mode) seems to generally work in 2.10 (tested with OSGeo4W-Release) against QGIS-Server and UMN-MapServer.
But from now on the BBOX of an added layer is immutable, so the wfs-layer in non-cach-mode doesn't get updated on panning the map (and though changing the bbox) - with all three kinds of OS-WFS-Servers (QGIS-Server, UMN-MapServer and GeoServer).

#9 Updated by Giovanni Manghi almost 4 years ago

  • Target version deleted (Version 2.10)

#10 Updated by Benjamin Schepers over 3 years ago

  • Status changed from Open to Closed

it seems, that this was fixed in master 188625c

I hope, this will come to 2.14: https://github.com/qgis/QGIS/commits/master/src/providers/wfs/qgswfsprovider.cpp

Also available in: Atom PDF