Bug report #11896

Messy label backgrounds

Added by Paolo Cavallini almost 6 years ago. Updated almost 3 years ago.

Status:Open
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:3.0.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20108

Description

When using curved labels with a background, a separate background (e.g. a rectangle, svg) is drawn for each character, with rather ugly results. For better results the "size type" of the background must be set to "fixed" (and then give it the proper size), but this does not solve the issue.

bad.png (21.1 KB) Paolo Cavallini, 2015-01-22 10:51 AM

History

#1 Updated by Larry Shaffer almost 6 years ago

  • Assignee set to Larry Shaffer

Hi Paolo,

Can you add some screen shots as to what is 'ugly' and what is desired?

#2 Updated by Paolo Cavallini almost 6 years ago

One example here. I think a more uniform shape would be more reasonable.
Thanks.

#3 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 2.8 to Version 2.8.2

#4 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 2.8.2 to Version 2.10

#5 Updated by Giovanni Manghi about 5 years ago

  • Target version deleted (Version 2.10)

#6 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#7 Updated by Paolo Cavallini almost 3 years ago

  • Affected QGIS version changed from 2.6.0 to 3.0.0

Still true in QGIS3.

#8 Updated by Giovanni Manghi almost 3 years ago

  • Assignee deleted (Larry Shaffer)

Also available in: Atom PDF