Bug report #11664

Locking selected items button in print composer freeze too much.

Added by Seb Radzimski almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.6.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:19915

Description

Hi folks!
I have a problem with print composer. In QGIS 2.6 locking selected items button completely freeze objects (maps, labels) so I can’t change map scale or label text (it is impossible to choose/change locked items properties). In previous versions of QGIS 'lock selected items' button locked position of object on a ‘sheet’, but it was possible to choose other item and change its properties (scale, etc.). So this is why I am confused...is it right or wrong? Anyway how can I (in QGIS 2.6) lock object position without freezing all item properties?
Regards!

History

#1 Updated by Nyall Dawson almost 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

A couple of things to note:

- While you can't select locked items in the composer canvas, you CAN select them using the "items panel" (choose View->Panels->Items if this isn't visible).
- Locked items can be individually unlocked via the items panel
- All locked items can be unlocked at once via the "Unlock all" toolbar button.

Hope that helps!

#2 Updated by Seb Radzimski almost 5 years ago

Thanks! Yes I know ... but for my users (usually 40-50 years old engineers) this change is impossible to understand ;)
So I see it is a feature - not a bug!
Cheers!

#3 Updated by Nyall Dawson almost 5 years ago

Yes - it definitely is a feature! The rationale is that it allows you to lock an item which is stacked above items (for instance, a rectangular border) and freely interact with the items below it. It's the standard behaviour for design programs, and very handy when you get the hang of it.

#4 Updated by Seb Radzimski almost 5 years ago

One more thing! I've noticed that on locked map item I can change scale or rotation but I can't use 'move map content' button. I understand the idea but possibility of locking positions of items on a sheet was very useful.
Regards.

Also available in: Atom PDF