Bug report #11657

Ordinary kriging in SAGA not saving output grids

Added by Rocco Panciera almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.6.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:19908

Description

I am running QGIS 2.6.0 Brighton on a Mac Lion 10.7.5

When running the ordinary kriging module of SAGA from the Processing toolbox I get the error indicated at the bottom.

the log file (attached as text files) indicates an initial "Error: library"

and then
"Error: Grid file could not be opened."
"Error: executing tool [GDAL: Export Raster]"

the problem seems to be associated with the GDAL plugin being unable to read the .sgrd.tif grids.
I tried a fix suggestion of disabling the GDAL plugins to avoid conflict with SAGA but it did not solve the problem

ERROR
"Oooops! The following output layers could not be open
Grid: /Users/panr/Desktop/dummy1.tif
Variance: /Users/panr/Desktop/dumy2.tif
The above files could not be opened, which probably indicates that they were not correctly produced by the executed algorithm
Checking the log information might help you see why those layers were not created as expected
This algorithm requires SAGA to be run. A test to check if SAGA is correctly installed and configured in your system has been performed, with the following result:
SAGA seems to be correctly installed and configured"

Log_report.txt Magnifier - Processing log file (3.51 KB) Rocco Panciera, 2014-11-16 03:54 AM

History

#1 Updated by Paolo Cavallini almost 6 years ago

  • Status changed from Open to Feedback

Are you sure you have used the correct parameters? If not (and this is quite likely), no output will be generated, and you'll get the error described.

#2 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

the SAGA library were ordinary kriging belongs changed name from 2.0.8 to 2.1.*. Was geostatistics_kriging and now is statistics_kriging.

So this means that you have recent SAGA installation but in Processing configurations you have checked the option to use SAGA 2.0.8 modules definitions.

Also available in: Atom PDF