Feature request #11555

attribute table toolbar - delete selected rows icon and remove selection icon too similar and are close together

Added by Andrew Mitchell about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Attribute table
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:19825

Description

Given that deleting rows could be bad, I think that the delete selected rows icon should be placed as far away from other regularly used toolbar icons as possible. Currently I don't think the attribute table toolbar can be customised, so I can't do this myself. If the delete selected rows button is pushed, there is no confirm dialog and there is no undo function so the delete selected rows feature currently breaks interface guidelines that are in general use about minimising the potential for accidental use of a potentially destructive function. I would put the delete selected rows button to the right of the old field calculator button.


Related issues

Duplicates QGIS Application - Bug report #9604: Attribute table: the icons for "Unselect all" and "Delete... Closed 2014-02-19

History

#1 Updated by Nathan Woodrow about 5 years ago

Yeah there is already a ticket for this somewhere here with icons in the works. Once I find it I will link here and close this one.

#2 Updated by Jürgen Fischer about 5 years ago

  • Tracker changed from Bug report to Feature request

There is undo.

#3 Updated by Jürgen Fischer about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #9604

Also available in: Atom PDF