Bug report #11540

Cannot load http_digest authenticated WMS

Added by armin11 - almost 6 years ago. Updated almost 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:2.6.0 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:19810

Description

QGIS 2.6 is not able to load http_digest authenticated WMS any longer :-( .
If some WMS and users / password to test is needed, feel free to ask - I will create dummies for this ;-) .

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback

yes please, add a url that we can test.

#3 Updated by Jürgen Fischer almost 6 years ago

Did you just fix the server? I could reproduce the problem - but not anymore.

#4 Updated by Jürgen Fischer almost 6 years ago

  • Operating System changed from Unbuntu to Ubuntu

#5 Updated by armin11 - almost 6 years ago

Hi Jürgen - fixed the Server? Maybe the credentials are stored somewhere an reused by QGIS?

#6 Updated by Anita Graser almost 6 years ago

  • Subject changed from WMS Interface to Cannot to load http_digest authenticated WMS

#7 Updated by armin11 - almost 6 years ago

I altered the email of the user to authenticate to armin.retterath(at)gmail.com.
Therefor you have to use:
username: 'testqgis26;armin.retterath(at)gmail.com'
password: 'testqgis26'

We noticed, that some java http_auth libs have problems with the @ sign ;-) - but this should be a bug in the java libs

#8 Updated by Paolo Cavallini almost 6 years ago

  • Subject changed from Cannot to load http_digest authenticated WMS to Cannot load http_digest authenticated WMS

#9 Updated by Giovanni Manghi almost 5 years ago

  • Target version deleted (Version 2.6)

#10 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Feedback to Open

#11 Updated by Giovanni Manghi almost 4 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

Test credentials and/or server are not valid anymore.
Closing also because WMS behind basic http authentication works as expected (while we know the wfs client has some issues storing the username).
Please reopen if necessary.

Also available in: Atom PDF