Bug report #11410

QGIS crashes when rendering all layers from a SOSI file at once

Added by Stefan Blumentrath almost 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Data Provider/OGR
Affected QGIS version:master Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:Yes Copied to github as #:19689

Description

QGIS crashes when rendering SOSI files, when all included layers are imported and made visible at once. QGIS crashes with "qgis-dev.exe has stopped working". In order to reproduce the issue it may need more that one SOSI file to cause the crash (open a SOSI file, click select all layers and then OK).
Using GDAL 1.11.0 and gdal-sosi 1.11.0-2

I can provide example files if needed.

Last line in DebugView is:
[11540] c:\\src\\qgis\\src\\providers\\ogr\\qgsogrprovider.cpp(872) : (QgsOgrProvider::extent) Starting get extent

Possibly related to #10746

Kystkontur_generalisert.zip - Testfile 1 (1.69 MB) Stefan Blumentrath, 2014-10-16 03:43 AM

NATURTYPER.zip - Testfile 2 (1.51 MB) Stefan Blumentrath, 2014-10-16 03:43 AM

NATVERNOMR.zip - Testfile 3 (781 KB) Stefan Blumentrath, 2014-10-16 03:43 AM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback
  • Priority changed from Normal to High

yes please, send/attach sample files. Thanks!

#2 Updated by Stefan Blumentrath almost 6 years ago

Best way to reproduce the issue is to open all three files and then select all layers at import...

#3 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Feedback to Open
  • Affected QGIS version changed from 2.4.0 to master

#4 Updated by Sandro Santilli over 4 years ago

  • Status changed from Open to Feedback

Can you still reproduce with current master (2.14-pre) ?
If so, can you also reproduce by loading a spatialite file rather than those SOSI files (I couldn't figure out how to load the SOSI file for testing)

#5 Updated by James Stott over 4 years ago

I have just tested with Master from OSGeo4w.

The first time I opened NATVERNOMR.sos, it didn't crash QGIS, but the file was not rendered correctly. It did not show all the geometry types correctly. Sometimes you see only the lines, other times only the polygons, and occasionally the points.

When I then added NATURTYPER.sos to QGIS, it instantly crashed.

After this I cannot get Naturvern.sos to render or show data in the attribute table. However naturtyper.sos opens, but has the same display problems that it will not display all geometry types at once. Eventually QGIS crashes with both files open again.

Do you have an example spatialite file I can try for you to reproduce?

#6 Updated by Stefan Blumentrath over 4 years ago

Unfortunately, it seems that the Norwegian Mapping authority (Kartverket) discontinued the work on the SOSI-driver for GDAL, as there is no progress for more than a year now:
https://github.com/kartverket/fyba/issues/9

Sad, but maybe best to close this issue as wontfix, until Kartverket updates the driver?

#7 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to up/downstream
  • Status changed from Feedback to Closed

Stefan Blumentrath wrote:

Unfortunately, it seems that the Norwegian Mapping authority (Kartverket) discontinued the work on the SOSI-driver for GDAL, as there is no progress for more than a year now:
https://github.com/kartverket/fyba/issues/9

Sad, but maybe best to close this issue as wontfix, until Kartverket updates the driver?

closing as "upstream", as seems really the issue must be fixed anyway in gdal first.

Also available in: Atom PDF