Bug report #10746

Buzzer sound when the map is refreshing

Added by Jerome Alary over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:2.4.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:19130

Description

When I pan the map, I can hear a buzz sound from my speakers.

See it here : http://youtu.be/Yz6xHRrCJmw

History

#1 Updated by Jerome Alary over 5 years ago

In QGIS 2.4

#2 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.6 to Future Release - High Priority

#3 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to Feedback
  • Target version changed from Future Release - High Priority to Version 2.6
  • Affected QGIS version changed from 2.2.0 to 2.4.0

Well... this is new :)

Anyway it looks like a local issue... can you replicate on another machine?

#4 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.6 to Future Release - High Priority

#5 Updated by Tobias Schneider over 5 years ago

This should help (probably faulty hardware in my opinion):

http://superuser.com/search?q=speaker+buzzing

#6 Updated by Jerome Alary over 5 years ago

  • Target version changed from Future Release - High Priority to Future Release - Lower Priority

Find out that the sound is only present when using layers from my Dropbox.
I was not able to reproduce on another computer and it is not doing this with QGIS 2.2.
Seem's like a computer issue (Dell L502x) and not QGIS.

#7 Updated by Nathan Woodrow over 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

#8 Updated by Joern Caro over 5 years ago

Jerome Alary wrote:

Find out that the sound is only present when using layers from my Dropbox.
I was not able to reproduce on another computer and it is not doing this with QGIS 2.2.
Seem's like a computer issue (Dell L502x) and not QGIS.

I have the same annoying sound.
I'm not using a Dell and i am not using dropbox.
It occurs even when one local shapefile is displayed.
QGis 2.4 on Windows 8.1

#9 Updated by Gilles V over 5 years ago

Joern Caro wrote:

Jerome Alary wrote:

Find out that the sound is only present when using layers from my Dropbox.
I was not able to reproduce on another computer and it is not doing this with QGIS 2.2.
Seem's like a computer issue (Dell L502x) and not QGIS.

I have the same annoying sound.
I'm not using a Dell and i am not using dropbox.
It occurs even when one local shapefile is displayed.
QGis 2.4 on Windows 8.1

Agreed, same problem. Refreshing causes a buzz. Windows 7, qgis 2.4.
The file I used to test this is the same as the one I used two days ago, with qgis 2.2, when no buzz sound would occur.

#10 Updated by Gilles V over 5 years ago

Forgot : local files, with dropbox sync.

#11 Updated by Jerome Alary over 5 years ago

  • Status changed from Closed to Reopened

Since I'm not the only one now, let's reopen it.

#12 Updated by Jürgen Fischer over 5 years ago

Jerome Alary wrote:

Since I'm not the only one now, let's reopen it.

QGIS doesn't do any sound output - even the GRASS terminal window doesn't do beeps - just visual bells. I suppose the multithreaded renderer takes some machines to strange new worlds of load where no application has gone before.

Are you using any other applications that produce a lot of load?

#13 Updated by Jerome Alary over 5 years ago

No other applications running crazy at the same time.

I had the reflect to log this issue because my project used to work in QGIS 2.2 last week. It is still working good in 2.4, but the first thing I realized after installing 2.4 is that sound.

#14 Updated by Jerome Alary over 5 years ago

Was able to reproduce on 3 different machines :

If a layer (SHP, TAB) is within a folder with special character (for example : C:\\Québec) sound will come out.

#15 Updated by Nathan Woodrow over 5 years ago

  • Resolution deleted (invalid)

Can we have some sample data?

#16 Updated by Jerome Alary over 5 years ago

Here it is:

https://www.dropbox.com/s/fft2fq3r1eyv2z3/Sample_10746.zip

You can hear the buzz sound by opening the attribute table as well

#17 Updated by Nathan Woodrow over 5 years ago

I have track this down to a error in the ogr_SOSI plugin.

If you remove the plugin the sound no longer occurs.

You can test by running the following in a Python console in OSGeo4W shell

import osgeo.ogr
ds = osgeo.ogr.Open("test,test.shp")

Seems like it's throwing an exception but you never see the message box only the sound.

#18 Updated by Jürgen Fischer over 5 years ago

Nathan Woodrow wrote:

I have track this down to a error in the ogr_SOSI plugin.

Please test gdal-sosi-1.10.1-2 in osgeo4w.
That fixes the file locking in SOSI and makes it work - maybe it also fixes the noise issue (btw. the new packages also contain some patches for NAS, Pg, MSSQL and add GeoPDF support).

#19 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Reopened to Feedback

#20 Updated by James Stott over 5 years ago

I still get the noise today with updated gdal-sosi.

For me, when the noise occurs its a sure sign that QGIS will close shortly afterwards. I do not get the noise with SOSI files that work fine in QGIS.

#21 Updated by James Stott over 5 years ago

I do not get the noise on Windows 8 and QGIS does not crash with SOSI files on Windows 8 - it is just a problem on Windows 7 for me. I have now tested with two Windows 8 machines, and both work. We have tested with many Windows 7 machines, and they all get the noise when SOSI files.

#22 Updated by Andreas B over 5 years ago

I have the exact same problem; buzz sounds when QGIS (2.4) refreshes the map. Sitting on a Dell Precision T5400 on Windows 7.

#23 Updated by Nathan Woodrow over 5 years ago

  • Tag set to ogr

A quick fix is to rename the ogr_SOSI.dll file to something else so that ogr doesn't pick it up. The error is in that plugin.

#24 Updated by Vitor Jorge about 5 years ago

  • Target version changed from Future Release - Lower Priority to Future Release - High Priority

I had the same problem at my job but I thought at the time that it was a hardware problem (Old computer with windows XP), but I'm now facing the same problem with mine new laptop (Windows 8.1, 64-bit machine with a quad core processor and 16GB RAM).

And the problem is not simply the beeps...whenever the application processes something the sounds occurs and it slows down. For example... when simply selecting a feature (ex. polygon) or opening the attribute table it turns very slow. E.g. a dataset with few records takes almost 30 seconds - something that was almost instant in QGIS 2.2 Valmiera.

I'm working with one local shapefile and that file isn't within a folder with special character.

Gdal-sosi v. 1.11.0-2

Renaming ogr_SOSI.dll fixed all the problems (I did it minutes ago) but it would be nice that everything functioned perfectly from the start without the need for renaming files.

#25 Updated by Stefan Blumentrath about 5 years ago

Maybe the source for the sound is somewhere here: http://github.com/kartverket/fyba/blob/master/src/UT/UT3.cpp (search for UT_Sound in Line 46)?
http://github.com/kartverket/fyba contains the source code of the underlying library the plugin is built upon. I am not ware of similar issues on other OSes...

#26 Updated by Giovanni Manghi about 5 years ago

I have also seen this for the first time on a pc (win 7) of a friend that made the osgeo4w installation by selecting everything. I solved by removing everything and reinstalling just what was needed.

it seems to me that this ticket should be closed here, and eventually filed in the osgeo4w tracker or in the tracker of who develops/manages the code for this plugin.

#27 Updated by Stefan Blumentrath about 5 years ago

Not sure either where this ticked belongs. Seems to be the interplay between QGIS (Multithreaded rendering) - GDAL/OGR - OpenFYBA.
It does not occure on every system either. I have for example a Win7 box with QGIS and gdal_sosi package installed through OSGeo4W, and I never heard the sound...
Is`nt the plugin also part of the QGIS standalone installer?

#28 Updated by Giovanni Manghi about 5 years ago

Is`nt the plugin also part of the QGIS standalone installer?

I don't think so, but not sure 100%

#29 Updated by Nathan Woodrow about 5 years ago

Stefan Blumentrath wrote:

Not sure either where this ticked belongs. Seems to be the interplay between QGIS (Multithreaded rendering) - GDAL/OGR - OpenFYBA.
It does not occure on every system either. I have for example a Win7 box with QGIS and gdal_sosi package installed through OSGeo4W, and I never heard the sound...
Is`nt the plugin also part of the QGIS standalone installer?

This doesn't have anything to do with QGIS multithreaded rendering. It's all in OGR itself and that plugin. You can hear it like I did when testing using ogr on the command line. This seems to only happen with 64bit installs though, so even if you install using OSGeo4W unless you install the 64bit version you will not hear it.

#30 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to up/downstream

#31 Updated by Stefan Blumentrath about 5 years ago

Just for the record: I never got the sound on my 32bit Win7 laptop with gdal-sosi installed. But when I open data from a folder with a name containing special characters (fot a test I used a folder named "Québec", like Jerome Alary did), then the noise is there also on my (until then quiet) 32bit system.

#32 Updated by Nicolas Boisteault about 5 years ago

I had the same problem with QGIS 2.4 64 bits. My dataset was in a folder named 'Données', I removed the accent and it solved the problem.

#33 Updated by Jürgen Fischer about 5 years ago

Please test with GDAL from OSGeo4W testing (invoke setup-test.bat from the OSGeo4W shell). GDAL 1.11.1 was rebuilt with openfyba as of today (https://github.com/kartverket/fyba/issues/17).

#34 Updated by Jürgen Fischer about 5 years ago

See also GDAL #5710

Also available in: Atom PDF