Bug report #11361

Cannot right click on vector layer in TOC when its table of attributes is open on KDE

Added by Giovanni Manghi almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Martin Dobias
Category:Map Legend
Affected QGIS version:master Regression?:No
Operating System:Linux KDE Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19652

Description

It happens on master, and is a regression.

Associated revisions

Revision 5e549125
Added by Martin Dobias almost 5 years ago

Fix #11361 (Cannot open menu for vector layer in TOC when its table of attributes is open)

Dual view's attribute form was triggering canvas refresh which in turn
caused the popup menu to be closed again. (at least in KDE)

History

#1 Updated by Salvatore Larosa almost 5 years ago

if it is enough to load a layer, open the attribute table and then right click on layer to access to the properties dialog, then I cannot confirm the issue in the latest master.

is there anything else to do to raise to the problem?

#2 Updated by Giovanni Manghi almost 5 years ago

in my case it happens on kde but not on Windows.

#3 Updated by Etienne Trimaille almost 5 years ago

Yes, I'm on KDE too.

This bug happens with a shapefile in my case.
With a geojson or WFS, it works fine.

#4 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from Open to Feedback

Not produceable here (tested shapefiles and postgres) either on Linux (XFCE) nor Windows

#5 Updated by Giovanni Manghi almost 5 years ago

  • Subject changed from Cannot right click on vector layer in TOC when its table of attributes is open to Cannot right click on vector layer in TOC when its table of attributes is open on KDE
  • Operating System set to Linux KDE
  • Status changed from Feedback to Open

it seems to be a KDE only issue.

#6 Updated by Martin Dobias almost 5 years ago

  • Assignee set to Martin Dobias

#7 Updated by Martin Dobias almost 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF