Bug report #11292

Print Composer breaks templates that work in 2.4

Added by ramon . about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System:win7-64bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19588

Description

In b044d4d (intstalled 30Sep via OSGeo4W) the print composer exhibits a number of problems loading templates that work in QGIS 2.4 (e.g.2-4ComposerFromTemplate).

1. Does not observe page orientation in existing templates (2-5ComposerFromTemplate).

2. Some objects in 2.5 are considered wrt different points (top left of page for objects that intersect the page and bottom left of the page for objects that are off the page), meaning that when the page orientation is fixed, objects are moved about when if they stayed still they'd be in the write place (2-4ComposerFromTemplate2).

I've set to major as it doesn't corrupt anything - but it does stop things that worked previously from working. It's also a bit irritating to have to go through and fix my print templates twice in two years.

2-4ComposerFromTemplate.png - Template opened in 2.4 - the crosses are images on a remote server. (79 KB) ramon ., 2014-09-29 10:03 PM

2-5ComposerFromTemplate.png - Template opened in 2.5 - print composer retains default landscape orientation. (95.1 KB) ramon ., 2014-09-29 10:03 PM

2-5ComposerFromTemplate2.png - Objects off the page move relative to the page when the page orientation is corrected. (110 KB) ramon ., 2014-09-29 10:03 PM

History

#1 Updated by ramon . about 5 years ago

Probably related in some way to #11255

#2 Updated by Nyall Dawson about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #11255

Also available in: Atom PDF