Bug report #11255

Composer does not update the paper size in QGIS Master

Added by Pedro Venâncio about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:19555

Description

Composer in QGIS Master does not update the paper size when opening a saved template.

To reproduce:

1. Create a new print composer (A4 by default);
2. Open a saved template with different format (A3, A2, ...);
3. The paper size remains at A4.

Tested both on Windows and Linux.

composer_2_5.jpg (62.2 KB) Pedro Venâncio, 2014-09-30 01:38 AM

History

#1 Updated by ramon . about 5 years ago

Probably related at some level to #11292

#2 Updated by Nyall Dawson about 5 years ago

  • Status changed from Open to Feedback

are you able to confirm the steps
you do to make the new composition from a template? Specifically, are
you creating a blank composition and using the "Add items from
template" command, or using the composer manager to create new
composition based off a template?

#3 Updated by Pedro Venâncio about 5 years ago

Hi Nyall,

The first one. I make "New print composer" and then "Add items from template".

I tested right now with QGIS 2.5.0-86 on windows and the result is in the image attached.

#4 Updated by Pedro Venâncio about 5 years ago

Ok, this is not a bug, but a change in functioning in version 2.6. Yet, I think icons do not seem very explicit. "New from template" icon is the same of "New composer". And "Add items from template" has the same icon that in previous versions were used to "Open" previously saved templates. So, it seems to me that should change the icons in any way.

#5 Updated by Nyall Dawson about 5 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Closing, as it's new intended behaviour. We'll tackle the icon discussion via the UI list.

Also available in: Atom PDF