Bug report #11060

ui: qt guru needed to adjust new color picker widget's positioning

Added by Mathieu Pellerin - nIRV about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19394

Description

On windows platform (using the default QT Plastique style/theme), the new color picker widget (thanks Nyall, fantastic job!) doesn't play well with the UI. It's often vertically misaligned (see attached screenshot for one of the worse of such misalignment), and its height is excessively tall when compared to other widgets (drop-down list, buttons, etc.).

Before the release of QGIS 2.6, I think it'd good for one QT GUI guru to have a look at this and try to improve things so QGIS looks acceptable on windows.

(Filling this as per a discussion with Nyall)

color_picker-simple_fill.png (126 KB) Mathieu Pellerin - nIRV, 2014-08-14 07:40 PM

Associated revisions

Revision 31c055d2
Added by Nyall Dawson about 5 years ago

Fix some alignment and tab issues with symbol dialogs (refs #11060)

Revision 8766cd18
Added by Nyall Dawson about 5 years ago

Add a platform-specific size hint for QgsColorButtonV2 (refs #11060)

History

#1 Updated by Leyan Ouyang about 5 years ago

I can't reproduce it with Windows 7. I tried with different styles, different font sizes, but it is always correctly aligned.

#2 Updated by Mathieu Pellerin - nIRV about 5 years ago

Leyan, screenshot?

#3 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Open to Feedback

Mathieu - this can be closed now, right?

#4 Updated by Mathieu Pellerin - nIRV almost 5 years ago

  • Resolution set to fixed/implemented
  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed

absolutely

Also available in: Atom PDF