Bug report #11009

WMS Server returns no search results if layer max scale is set to 1:1

Added by luca76 - about 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:QGIS Server
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:19351

Description

As subject.

If you do a wms search (i.e. with qgis web client) on a layer that has defined scale visibility, it could return always zero results.

If the maximum scale is set to 1:1 -> ALWAYS zero results.

If the maximum scale is set to 1:0 -> WMS Search is working.

History

#1 Updated by Alessandro Pasotti about 6 years ago

  • Priority changed from Severe/Regression to Normal
  • Status changed from Open to Feedback

I cannot reproduce on current master.
Can you please provide a sample project and the query string that fails?

#2 Updated by Giovanni Manghi almost 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

closing for lack of feedback. Please reopen if necessary.

Also available in: Atom PDF