Bug report #10898

Date/Time and other edit widgets do not have 'allow null value' option

Added by Gavin Fleming over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:19263

Description

All or most widgets should have an 'allow NULL value' option but only some do.

At the moment if you use the date/time widget without this option then these fields default to the current system date which in most cases is not the intended value, facilitating easy data corruption.

QGIS version 2.5.0-Master QGIS code revision exported
Compiled against Qt 4.8.6 Running against Qt 4.8.6
Compiled against GDAL/OGR 1.11.0 Running against GDAL/OGR 1.11.0
Compiled against GEOS 3.4.2-CAPI-1.8.2 Running against GEOS 3.4.2-CAPI-1.8.2 r3921
PostgreSQL Client Version 9.3.4 SpatiaLite Version 4.1.1
QWT Version 5.2.3 PROJ.4 Version 480
QScintilla2 Version

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #10882

Also available in: Atom PDF